Page 1 of 1

Version 1.21.1 bugs

Posted: Thu May 17, 2018 12:34 pm
by PlanoBill
I just recently purchased and installed HomeControl version 1.21.1 on my MacBook Pro running OSX 10.11.6. I am trying to control some TP-link HS105 mini-plugs. The program discovers them and I can turn them on/off from the device list. However, if a put the devices in a group and try to use the Group Control panel, clicking on the group icon has no effect. If I turn them on/off from the device list, the on indicator on the Group Control panel does reflect their state but I can't control them from the Group Control panel. However, I can control them from the group drop down from the menu bar icon.
Additionally, the Scene Control Menu isn't displaying correctly. The Scene list portion of the panel has a black background and the text is invisible. If I click in the Scene list, I can select an item and it becomes visible with white text within a blue selection box.
I installed the program on a different Mac, a MacBook Air running OS X 10.11.6, and the same behavior was observed.

Re: Version 1.21.1 bugs

Posted: Thu May 17, 2018 12:41 pm
by DaveSignal
Strange. What happens if you put just one HS105 in a group by itself?

It is possible that something is not right with one of your switches. Maybe it is not on the network or not responding correctly. Other users have reported successfully working with the HS105, so it could be a device issue.

Re: Version 1.21.1 bugs

Posted: Thu May 17, 2018 4:51 pm
by PlanoBill
The behavior is the same whether there's just one or both in a group. Both HS105's have the latest firmware version 1.5.1.

Both devices work with the Kasa app. Both devices can be controlled by HomeControl, but not with the Group Control panel.

I have attached a couple of screen shots of the scene control panel issue

Re: Version 1.21.1 bugs

Posted: Thu May 17, 2018 5:40 pm
by DaveSignal
Damn. Can you toggle the groups by double-clicking from the group list? (command+G)

Re: Version 1.21.1 bugs

Posted: Thu May 17, 2018 6:21 pm
by PlanoBill
Yes, I can toggle the group from group list.

Re: Version 1.21.1 bugs

Posted: Thu May 17, 2018 6:58 pm
by DaveSignal
Both the Group Control and the blacked-out part of the Scene Control use visual effect views that kind of blend with the desktop background. I am surprised that OSX 10.11 does not support this implementation, but it is possible that your computers are too old to work with this setup. I think I have a solution for the scene control. I am not sure if disabling the effect view on the Group Control is a solution, though. Does the button show any kind of animation when you click on it? If it doesn't do anything at all, maybe disabling the click animation for 10.11 would fix it.

Re: Version 1.21.1 bugs

Posted: Thu May 17, 2018 8:14 pm
by PlanoBill
There's really not any animation when I click on a button on the Group Control panel. If I single click or double click a button, the button outline becomes thicker. However, no matter how many times I click the button again, the button outline remains thicker and does not toggle.

Re: Version 1.21.1 bugs

Posted: Thu May 17, 2018 8:18 pm
by DaveSignal
hmmm... for some reason 10.11 is not responding to a mouse-up. I will just make everything function on mouse-down for 10.11 then. It should work. I'm working on it now.

Re: Version 1.21.1 bugs

Posted: Thu May 17, 2018 8:55 pm
by DaveSignal
OK. I have an idea that makes sense, at least I think it sounds reasonable. It should fix the Group Control buttons and the Scene List view for users running OSX 10.11. I have uploaded a new build (1.21.2). It is waiting on App Review, but will probably be available for download either later tonight or tomorrow morning.

I don't have a computer running 10.11 to test this, so I don't actually know if its going to work on your system. If it doesn't work, there are a few other things I can still try.

- Dave

Re: Version 1.21.1 bugs

Posted: Fri May 18, 2018 1:13 pm
by PlanoBill
I just installed version 1.21.2. It has fixed both the problems with the Group Control buttons and Scene list view.

Thanks for your support!

Re: Version 1.21.1 bugs

Posted: Fri May 18, 2018 2:42 pm
by DaveSignal
Great! Thank you for letting me know about this. I thought this one might be tricky because I couldn't replicate it, but it was an easy fix. I am glad that you found it and said something because other users on El Capitan were probably experiencing the same thing and never reported the issue.

- Dave